SCA: security update for dd-trace (GHSA-x94g-w73q-hpcw)

high Tenable Cloud Security Plugin ID 477687

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- dd-trace is the Datadog APM client for Node.js. From 2.0.0 until 5.131.1 and 6.20.1, the default
DD_TRACE_OBFUSCATION_QUERY_STRING_REGEXP can perform excessive backtracking on attacker-controlled URL
query strings. The expression is applied synchronously while recording HTTP URL metadata, allowing a
crafted request to consume excessive CPU, stall request processing, and make the instrumented application
unavailable. This issue is fixed in versions 5.131.1 and 6.20.1. (CVE-2026-116693)

Solution

Update the dd-trace library and its related packages to version 5.131.1 or later.

See Also

https://github.com/advisories/GHSA-x94g-w73q-hpcw

Plugin Details

Severity: High

ID: 477687

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/28/2026

Updated: 10/28/2026

Risk Information

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2026-116693

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.7

Threat Score: 6.6

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/27/2026

Vulnerability Publication Date: 10/27/2026

Reference Information

CVE: CVE-2026-116693