Description
There are packages installed that are affected by a vulnerability referenced in the following CVE:
- undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and
8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone
before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-
supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the
TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject,
but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the
default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications
use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications
that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key
pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls
option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should
upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead
of tls, or for proxied destinations use requestTls and proxyTls. (CVE-2026-109383)
Solution
Update the node-gyp library and its related packages to version 13.1.0-r1 or later.
Plugin Details
Risk Information
Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N
Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C
Vulnerability Information
Exploit Ease: No known exploits are available
Vulnerability Publication Date: 10/15/2026