Echo: python-git: security update to 3.2.0

high Tenable Cloud Security Plugin ID 477472

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- GitPython before 3.2.0 contains a remote code execution vulnerability that allows attackers to run
commands because Git.ls_remote forwards URLs without check_unsafe_protocols validation. Attackers can
supply ext:: remote-helper URLs to execute commands when git permits the ext transport, while merge_base
and IndexFile.move also accept unguarded option injection. (CVE-2026-110857)

Solution

Update the python-git library and its related packages to version 3.2.0 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-110857

Plugin Details

Severity: High

ID: 477472

Version: Revision 1.1

Type: Local

Published: 10/26/2026

Updated: 10/26/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.38

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-110857

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 7.7

Threat Score: 5.2

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/15/2026

Vulnerability Publication Date: 10/14/2026

Reference Information

CVE: CVE-2026-110857