Echo: python-git: security update to 3.2.0

high Tenable Cloud Security Plugin ID 477471

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- GitPython before 3.2.0 contains a regular expression denial of service vulnerability in the
_re_actor_epoch pattern used by parse_actor_and_date on author, committer, and tagger lines. Attackers can
serve repositories with commit or tag objects containing long space-filled lines lacking a valid epoch or
timezone, causing quadratic backtracking and CPU exhaustion. (CVE-2026-110856)

Solution

Update the python-git library and its related packages to version 3.2.0 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-110856

Plugin Details

Severity: High

ID: 477471

Version: Revision 1.1

Type: Local

Published: 10/26/2026

Updated: 10/26/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.74

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-110856

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.7

Threat Score: 6.6

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/15/2026

Vulnerability Publication Date: 10/14/2026

Reference Information

CVE: CVE-2026-110856