Echo: php-7.2: security update to 7.2.34+e1

high Tenable Cloud Security Plugin ID 477454

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions:8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.*
before 8.5.1, a heap buffer overflow occurs in array_merge() when the total element count of packed arrays
exceeds 32-bit limits or HT_MAX_SIZE, due to an integer overflow in the precomputation of element counts
using zend_hash_num_elements(). This may lead to memory corruption or crashes and affect the integrity and
availability of the target server. (CVE-2025-14178)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2025-14178

Plugin Details

Severity: High

ID: 477454

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 51.94

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:C

CVSS Score Source: CVE-2025-14178

CVSS v3

Risk Factor: High

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.3

Threat Score: 4.8

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 12/17/2025

Reference Information

CVE: CVE-2025-14178