Echo: php-7.2: security update to 7.2.34+e1

high Tenable Cloud Security Plugin ID 477451

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to
connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would
cause PHP to access a null pointer and thus cause a crash. (CVE-2021-21702)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2021-21702

Plugin Details

Severity: High

ID: 477451

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2021-21702

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 2/1/2021

Reference Information

CVE: CVE-2021-21702