Echo: php-7.2: security update to 7.2.34+e1

medium Tenable Cloud Security Plugin ID 477419

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, a hostile MySQL server can
cause the client to disclose the content of its heap containing data from other SQL requests and possible
other data belonging to different users of the same server. (CVE-2024-8929)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2024-8929

Plugin Details

Severity: Medium

ID: 477419

Version: Revision 1.2

Type: Local

Published: 10/25/2026

Updated: 10/27/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3.3

Percentile: 51.16

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:A/AC:H/Au:S/C:C/I:N/A:N

CVSS Score Source: CVE-2024-8929

CVSS v3

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 5.2

Vector: CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 10/25/2026

Reference Information

CVE: CVE-2024-8929