Chainguard: multiple ruby-3.3 packages: security update to 3.3.12-r10

critical Tenable Cloud Security Plugin ID 477194

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before
19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before
19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary
code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.
(CVE-2026-110264)

Solution

Update the ruby-3.3 library and its related packages to version 3.3.12-r10 or later.

Plugin Details

Severity: Critical

ID: 477194

Version: Revision 1.1

Type: Local

Published: 10/24/2026

Updated: 10/24/2026

Risk Information

VPR

Risk Factor: High

Score: 8

Percentile: 99.69

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-110264

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 10/22/2026

Reference Information

CVE: CVE-2026-110264