Echo: brotli: security update to 1.2.0-4+e1

critical Tenable Cloud Security Plugin ID 477151

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3
through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state
memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary
code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries
between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1. (CVE-2026-111497)

Solution

Update the brotli library and its related packages to version 1.2.0-4+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-111497

Plugin Details

Severity: Critical

ID: 477151

Version: Revision 1.3

Type: Local

Published: 10/23/2026

Updated: 10/29/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Critical

Score: 9.4

Percentile: 99.83

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-111497

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

CVSS v4

Risk Factor: Critical

Base Score: 9.2

Threat Score: 9.2

Threat Vector: CVSS:4.0/E:A

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/22/2026

Vulnerability Publication Date: 10/21/2026

Reference Information

CVE: CVE-2026-111497