Echo: php-7.2: security update to 7.2.34+e1php-8.1: security update to 8.1.34+e1

medium Tenable Cloud Security Plugin ID 476619

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6,
when SoapServer is configured with SOAP_PERSISTENCE_SESSION, the handler object is persisted across
requests via session storage. However, in the case SOAP requests results in an error, the persistance is
handled incorrectly, resulting in freeing the object while keeping a pointer to it, which may lead to use-
after-free. This may lead to memory corruption, information disclosure, or process crashes, with
confidentiality, integrity, and availability impact on the vulnerable system. (CVE-2026-7261)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-7261

Plugin Details

Severity: Medium

ID: 476619

Version: Revision 1.2

Type: Local

Published: 10/22/2026

Updated: 10/25/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 96.93

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-7261

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Medium

Base Score: 6.3

Threat Score: 1.7

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/22/2026

Vulnerability Publication Date: 5/6/2026

Reference Information

CVE: CVE-2026-7261