Echo: boost-1.69.0: security update to 1.69.0+e1boost-1.75.0: security update to 1.75.0+e1boost-1.84.0: security update to 1.84.0+e1zlib-1.2.11: security update to 1.2.11+e1

critical Tenable Cloud Security Plugin ID 476166

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a
large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some
common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g.,
see the nodejs/node reference). (CVE-2022-37434)

Solution

Update the zlib-1.2.11 library and its related packages to version 1.2.11+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2022-37434

Plugin Details

Severity: Critical

ID: 476166

Version: Revision 1.1

Type: Local

Published: 10/19/2026

Updated: 10/19/2026

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 96.41

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-37434

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/15/2026

Vulnerability Publication Date: 8/5/2022

Reference Information

CVE: CVE-2022-37434