Echo: python-git: security update to 3.1.57

high Tenable Cloud Security Plugin ID 474870

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- GitPython before 3.1.57 fails to guard git option forwarding in IndexFile.checkout() and
TagReference.create(), allowing attackers to pass unsafe options via kwargs. Attackers can use --prefix to
overwrite arbitrary files with repository content or -F to read arbitrary files returned in-band.
(CVE-2026-73620)

Solution

Update the python-git library and its related packages to version 3.1.57 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-73620

Plugin Details

Severity: High

ID: 474870

Version: Revision 1.2

Type: Local

Published: 10/16/2026

Updated: 10/16/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.41

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:C/A:C

CVSS Score Source: CVE-2026-73620

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 7.2

Threat Score: 5.7

Threat Vector: CVSS:4.0/E:P

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/14/2026

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-73620