Echo: python-git: security update to 3.1.54

high Tenable Cloud Security Plugin ID 474863

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- GitPython versions before 3.1.54 contain a remote code execution vulnerability in the check_unsafe_options
guard that can be bypassed by smuggling git options inside single-character kwarg values. Attackers can
supply crafted option dictionaries to clone_from, fetch, pull, push, ls_remote, iter_commits, blame, or
archive methods to execute arbitrary OS commands via the --upload-pack parameter. (CVE-2026-73625)

Solution

Update the python-git library and its related packages to version 3.1.54 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-73625

Plugin Details

Severity: High

ID: 474863

Version: Revision 1.1

Type: Local

Published: 10/16/2026

Updated: 10/16/2026

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 96.58

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-73625

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.7

Threat Score: 7.4

Threat Vector: CVSS:4.0/E:P

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/14/2026

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-73625