Echo: tornado: security update to 6.5

high Tenable Cloud Security Plugin ID 465462

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Tornado is a Python web framework and asynchronous networking library. When Tornado's ``multipart/form-
data`` parser encounters certain errors, it logs a warning but continues trying to parse the remainder of
the data. This allows remote attackers to generate an extremely high volume of logs, constituting a DoS
attack. This DoS is compounded by the fact that the logging subsystem is synchronous. All versions of
Tornado prior to 6.5.0 are affected. The vulnerable parser is enabled by default. Upgrade to Tornado
version 6.50 to receive a patch. As a workaround, risk can be mitigated by blocking `Content-Type:
multipart/form-data` in a proxy. (CVE-2025-47287)

Solution

Update the tornado library and its related packages to version 6.5 or later.

See Also

https://advisory.echohq.com/cve/CVE-2025-47287

Plugin Details

Severity: High

ID: 465462

Version: Revision 1.2

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.73

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2025-47287

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 8/12/2026

Vulnerability Publication Date: 8/12/2026

Reference Information

CVE: CVE-2025-47287