Echo: postgresql-15: security update to 15.18postgresql-17: security update to 17.10

high Tenable Cloud Security Plugin ID 461523

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Use of inherently dangerous function PQfn(..., result_is_int=0, ...) in PostgreSQL libpq lo_export(),
lo_read(), lo_lseek64(), and lo_tell64() functions allows the server superuser to overwrite a client stack
buffer with an arbitrarily-large response. Like gets(), PQfn(..., result_is_int=0, ...) stores arbitrary-
length, server-determined data into a buffer of unspecified size. Because both the \lo_export command in
psql and pg_dump call lo_read(), the server superuser can overwrite pg_dump or psql stack memory. Versions
before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected. (CVE-2026-6477)

Solution

Update the postgresql-15 library and its related packages to version 15.18 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-6477

Plugin Details

Severity: High

ID: 461523

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Medium

Score: 5

Percentile: 93.75

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-6477

CVSS v3

Risk Factor: High

Base Score: 8.4

Temporal Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 5/14/2026

Vulnerability Publication Date: 5/14/2026

Reference Information

CVE: CVE-2026-6477