Echo: apache-airflow: security update to 3.1.8

medium Tenable Cloud Security Plugin ID 460766

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG
authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a
result, version metadata of DAGs that the requester is not authorized to access is returned. Users are
recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue. (CVE-2026-26929)

Solution

Update the apache-airflow library and its related packages to version 3.1.8 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-26929

Plugin Details

Severity: Medium

ID: 460766

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.73

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2026-26929

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 7/1/2026

Vulnerability Publication Date: 3/17/2026

Reference Information

CVE: CVE-2026-26929