Echo: samba: security update to 2:4.0.13+dfsg-1

medium Tenable Cloud Security Plugin ID 460628

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The winbind_name_list_to_sid_string_list function in nsswitch/pam_winbind.c in Samba through 4.1.2 handles
invalid require_membership_of group names by accepting authentication by any user, which allows remote
authenticated users to bypass intended access restrictions in opportunistic circumstances by leveraging an
administrator's pam_winbind configuration-file mistake. (CVE-2012-6150)

Solution

Update the samba library and its related packages to version 2:4.0.13+dfsg-1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2012-6150

Plugin Details

Severity: Medium

ID: 460628

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: Low

Base Score: 3.6

Temporal Score: 2.8

Vector: CVSS2#AV:N/AC:H/Au:S/C:P/I:P/A:N

CVSS Score Source: CVE-2012-6150

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2026

Vulnerability Publication Date: 6/12/2012

Reference Information

CVE: CVE-2012-6150