Echo: pyasn1: security update to 0.6.1-1+deb13u2+e3

high Tenable Cloud Security Plugin ID 460507

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER decoder shared by the CER and DER
codecs parses long-form tags by accumulating continuation octets without an upper bound on the tag ID
size, allowing a crafted input to force construction of an arbitrarily large integer with CPU cost growing
quadratically and to trigger unhandled ValueError exceptions in Python 3.11+ error formatting paths. Any
application decoding untrusted BER, CER, or DER input is affected. This issue is fixed in version 0.6.4.
(CVE-2026-59884)

Solution

Update the pyasn1 library and its related packages to version 0.6.1-1+deb13u2+e3 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-59884

Plugin Details

Severity: High

ID: 460507

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.73

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-59884

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 7/15/2026

Vulnerability Publication Date: 7/14/2026

Reference Information

CVE: CVE-2026-59884