Echo: vm2: security update to 3.11.4

critical Tenable Cloud Security Plugin ID 459680

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, by combining
Buffer.call.call({}.__lookupGetter__, Buffer, "__proto__"), Buffer.call.call({}.__lookupSetter__, Buffer,
"__proto__"), and Node.js's ERR_INVALID_ARG_TYPE Error, the host's TypeError constructor can be obtained,
which allows the escape from the sandbox. This allows attackers to run arbitrary code. This issue has been
patched in version 3.11.4. (CVE-2026-47131)

Solution

Update the vm2 library and its related packages to version 3.11.4 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-47131

Plugin Details

Severity: Critical

ID: 459680

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Medium

Score: 5

Percentile: 94.36

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-47131

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 9/28/2026

Vulnerability Publication Date: 5/29/2026

Reference Information

CVE: CVE-2026-47131