Echo: litellm: security update to 1.78.0+echo.1

critical Tenable Cloud Security Plugin ID 459551

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0,
when JWT authentication is enabled (enable_jwt_auth: true), the OIDC userinfo cache uses token[:20] as the
cache key. JWT headers produced by the same signing algorithm generate identical first 20 characters. This
configuration option is not enabled by default. Most instances are not affected. An unauthenticated
attacker can craft a token whose first 20 characters match a legitimate user's cached token. On cache hit,
the attacker inherits the legitimate user's identity and permissions. This affects deployments with
JWT/OIDC authentication enabled. Fixed in v1.83.0. (CVE-2026-35030)

Solution

Update the litellm library and its related packages to version 1.78.0+echo.1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-35030

Plugin Details

Severity: Critical

ID: 459551

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.51

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2026-35030

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Critical

Base Score: 9.4

Threat Score: 8.1

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 5/5/2026

Vulnerability Publication Date: 4/3/2026

Reference Information

CVE: CVE-2026-35030