Echo: org.yaml:snakeyaml, snakeyaml: security update to 1.31

high Tenable Cloud Security Plugin ID 458927

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due
missing to nested depth limitation for collections. (CVE-2022-25857)

Solution

Update the org.yaml:snakeyaml library and its related packages to version 1.31 or later.

See Also

https://advisory.echohq.com/cve/CVE-2022-25857

Plugin Details

Severity: High

ID: 458927

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2022-25857

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/28/2026

Vulnerability Publication Date: 8/30/2022

Reference Information

CVE: CVE-2022-25857