Echo: fast-xml-parser: security update to 4.5.4

high Tenable Cloud Security Plugin ID 458901

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without
C/C++ based libraries and no callback. From 4.1.3to before 5.3.5, a dot (.) in a DOCTYPE entity name is
treated as a regex wildcard during entity replacement, allowing an attacker to shadow built-in XML
entities (<, >, &, ", ') with arbitrary values. This bypasses entity encoding and
leads to XSS when parsed output is rendered. This vulnerability is fixed in 5.3.5. (CVE-2026-25896)

Solution

Update the fast-xml-parser library and its related packages to version 4.5.4 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-25896

Plugin Details

Severity: High

ID: 458901

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3.1

Percentile: 49.12

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:C/A:N

CVSS Score Source: CVE-2026-25896

CVSS v3

Risk Factor: High

Base Score: 7.1

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/28/2026

Vulnerability Publication Date: 2/20/2026

Reference Information

CVE: CVE-2026-25896