Echo: github.com/rabbitmq/amqp091-go: security update to 1.13.0

critical Tenable Cloud Security Plugin ID 457432

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates
tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default
permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an
amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken
transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
(CVE-2026-77405)

Solution

Update the github.com/rabbitmq/amqp091-go library and its related packages to version 1.13.0 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-77405

Plugin Details

Severity: Critical

ID: 457432

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.39

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2026-77405

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Critical

Base Score: 9.4

Threat Score: 8

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 9/28/2026

Vulnerability Publication Date: 9/16/2026

Reference Information

CVE: CVE-2026-77405