Google: app-editors/vim, app-editors/vim-core: security update to 18244.1.19

medium Tenable Cloud Security Plugin ID 451851

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Vim is an open source command line text editor. When using the z= command, the user may overflow the count
with values larger than MAX_INT. Impact is low, user interaction is required and a crash may not even
happen in all situations. This vulnerability has been addressed in commit `73b2d379` which has been
included in release version 9.0.2111. Users are advised to upgrade. There are no known workarounds for
this vulnerability. (CVE-2023-48236)

Solution

Update the app-editors/vim library and its related packages to version 18244.1.19 or later.

See Also

https://storage.googleapis.com/cos-oval-vulnerability-feed/cos-113.oval.xml.tar.gz

Plugin Details

Severity: Medium

ID: 451851

Version: Revision 1.1

Type: Local

Published: 10/1/2026

Updated: 10/1/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

Vendor

Vendor Severity: LOW

CVSS v2

Risk Factor: Low

Base Score: 1.7

Temporal Score: 1.3

Vector: CVSS2#AV:L/AC:L/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2023-48236

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 11/16/2023

Reference Information

CVE: CVE-2023-48236