Google: dev-libs/glib: security update to 17927.0.0

high Tenable Cloud Security Plugin ID 450536

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- A flaw was found in glib, where the gvariant deserialization code is vulnerable to a denial of service
introduced by additional input validation added to resolve CVE-2023-29499. The offset table validation may
be very slow. This bug does not affect any released version of glib but does affect glib distributors who
followed the guidance of glib developers to backport the initial fix for CVE-2023-29499. (CVE-2023-32636)

Solution

Update the dev-libs/glib library and its related packages to version 17927.0.0 or later.

See Also

https://storage.googleapis.com/cos-oval-vulnerability-feed/cos-113.oval.xml.tar.gz

Plugin Details

Severity: High

ID: 450536

Version: Revision 1.1

Type: Local

Published: 10/1/2026

Updated: 10/1/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.63

Vendor

Vendor Severity: LOW

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-32636

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/7/2023

Reference Information

CVE: CVE-2023-32636