Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP < 5.4.38, < 5.5.22, < 5.6.6 HTTP Header Content Injection XSS

Medium

Synopsis

The specific version of PHP that this Apache server is running is vulnerable to a HTTP Header Content Injection XSS attack.

Description

PHP contains a flaw that allows a cross-site scripting (XSS) attack. This flaw exists because the header() function does not filter input passed via HTTP headers before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.Technical Information: This vulnerability is only present when using Internet Explorer.

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.