OL08-00-010163 - The krb5-server package must not be installed on OL 8.

Information

Unapproved mechanisms that are used for authentication to the cryptographic module are not verified and therefore cannot be relied on to provide confidentiality or integrity, and DoD data may be compromised.

OL 8 systems using encryption are required to use FIPS-compliant mechanisms for authenticating to cryptographic modules.

Currently, Kerberos does not use FIPS 140-2 cryptography.

FIPS 140-2 is the current standard for validating that mechanisms used to access cryptographic modules use authentication that meets DoD requirements. This allows for Security Levels 1, 2, 3, or 4 for use on a general-purpose computing system.

Solution

Document the krb5-server package with the ISSO as an operational requirement or remove it from the system with the following command:

$ sudo yum remove krb5-server

See Also

https://dl.dod.cyber.mil/wp-content/uploads/stigs/zip/U_Oracle_Linux_8_V1R2_STIG.zip

Item Details

Category: IDENTIFICATION AND AUTHENTICATION

References: 800-53|IA-7, CAT|II, CCI|CCI-000803, Rule-ID|SV-248547r779207_rule, STIG-ID|OL08-00-010163, Vuln-ID|V-248547

Plugin: Unix

Control ID: 69d621aa2a3f1943f17ae6e23e92495ab7c286857f1d6dffe87077333c1df82c