APPNET0061 - .Net Framework versions installed on the system must be supported.

Information

Unsupported software introduces risks and violates DoD policy. Applications utilizing unsupported versions of .NET introduce substantial risk to the host, network, and the enclave by virtue of the fact they leverage an architecture that is no longer updated by the vendor. This introduces potential application integrity, availability, or confidentiality issues.

NOTE: Nessus has provided the target output to assist in reviewing the benchmark to ensure target compliance.

Solution

Remove unsupported versions of the .NET Framework and upgrade legacy applications that utilize unsupported versions of the .NET framework.

See Also

https://dl.dod.cyber.mil/wp-content/uploads/stigs/zip/U_MS_DotNet_Framework_4-0_V2R2_STIG.zip

Item Details

Category: CONFIGURATION MANAGEMENT

References: 800-53|CM-6b., CAT|II, CCI|CCI-000366, Rule-ID|SV-225229r615940_rule, STIG-ID|APPNET0061, STIG-Legacy|SV-55642, STIG-Legacy|V-18395, Vuln-ID|V-225229

Plugin: Windows

Control ID: 5ae2f355794cb647a471553dde3ebe0471ca6b11bb39e6ac425a6a00ff65a0e9