CISC-RT-000130 - The Cisco switch must be configured to restrict traffic destined to itself.

Information

The route processor handles traffic destined to the switch-the key component used to build forwarding paths and is instrumental with all network management functions. Hence, any disruption or DoS attack to the route processor can result in mission critical network outages.

NOTE: Nessus has provided the target output to assist in reviewing the benchmark to ensure target compliance.

Solution

Step 1: Configure the ACL for any external interfaces as shown in the example below:

SW1(config)# ip access-list EXTERNAL_ACL
SW1(config-acl)# permit tcp host x.11.1.1 eq bgp host x.11.1.2
SW1(config-acl)# permit tcp host x.11.1.1 host x.11.1.2 eq bgp
SW1(config-acl)# permit icmp host x.11.1.1 host x.11.1.2 echo
SW1(config-acl)# permit icmp host x.11.1.1 host x.11.1.2 echo-reply
SW1(config-acl)# deny ip any host x.11.1.1 log
SW1(config-acl)# permit ...
...
...
...
SW1(config-acl)# deny ip any any log

Configure the ACL for any external interfaces as shown in the example below:

SW1(config)# ip access-list INTERNAL_ACL
SW1(config-acl)# permit ospf host 10.1.12.1 host 10.1.12.2
SW1(config-acl)# permit tcp 10.2.1.0 0.0.0.255 host 10.1.12.2 eq 22
SW1(config-acl)# permit tcp 10.2.1.0 0.0.0.255 host 10.1.12.2 eq tacacs
SW1(config-acl)# permit udp 10.2.1.0 0.0.0.255 host 10.1.12.2 eq snmp
SW1(config-acl)# permit udp 10.2.1.0 0.0.0.255 host 10.1.12.2 eq ntp
SW1(config-acl)# deny ip any host 10.1.12.2 log
SW1(config-acl)# permit ...
...
...
...
SW1(config-acl)# permit ip any any log
SW1(config-acl)# exit

Note: best practice is to configure the ACL statements relative to traffic destined to the switch first followed by ACL statements for transit traffic.

Step 2: Apply the ACLs to the appropriate interface as shown in the example below:

SW1(config)# int e1/2
SW1(config-if)# ip access-group EXTERNAL_ACL in
SW1(config)# int e1/3
SW1(config-if)# ip access-group INTERNAL_ACL in

See Also

https://dl.dod.cyber.mil/wp-content/uploads/stigs/zip/U_Cisco_NX-OS_Switch_Y23M10_STIG.zip

Item Details

Category: SYSTEM AND COMMUNICATIONS PROTECTION

References: 800-53|SC-7a., CAT|I, CCI|CCI-001097, Rule-ID|SV-221080r622190_rule, STIG-ID|CISC-RT-000130, STIG-Legacy|SV-110979, STIG-Legacy|V-101875, Vuln-ID|V-221080

Plugin: Cisco

Control ID: 53c9a17922cafdcfffef46366facd2f3ab880b18c0fdabc7d2f9c6c1d9ea78ae