Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

ISC BIND 9.x < 9.9.8-P2 / 9.9.8-S3 / 9.9.9-S3 / 9.10.3-P2 DoS

High

Synopsis

The remote DNS server may be affected by a Denial of Service (DoS) attack vector.

Description

Versions of ISC BIND prior to 9.9.8-P2, 9.9.8-S3, 9.9.9-S3 and 9.10.3-P2 are unpatched for a flaw in 'db.c' that is triggered when responses with incorrect class attributes are incorrectly parsed. This may potentially allow a remote attacker to trigger a REQUIRE assertion failure and cause a denial of service.

Solution

Upgrade ISC BIND to version 9.10.3-P2 or later. If version 9.10.x cannot be obtained, versions 9.9.9-S3, 9.10.2-P4, 9.9.8-S3, and 9.9.8-P2 are also patched for this vulnerability.