Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle < 3.1.1 Multiple Vulnerabilities

Medium

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 3.1.x prior to 3.1.1 are exposed to the following vulnerabilities :

- A flaw exists that is due to the program failing to perform permission checks on Glossary searches. This may allow a remote attacker to view entries via a glossary search. (CVE-2016-5012) - A flaw exists that may allow an authenticated remote attacker to inject email addresses into the intended recipients of an email by changing their username to include another user's email address. This may result in other users potentially being saturated with emails. (CVE-2016-5013) - A flaw exists in the event monitor tool that is triggered as notifications are still sent to users even after they can no longer access classes. This may allow an authenticated remote attacker to gain access to sensitive information in notifications. (CVE-2016-5014)

Solution

Upgrade to Moodle version 3.1.1 or later.