The remote host is using a version of Zend Framework that is vulnerable to a security bypass flaw.
Versions of Zend Framework earlier than 2.2.9, or 2.3.x earlier than 2.3.4 are vulnerable to a security bypass flaw in which session validators are not run if set before session start. Specifically, the validators write to the '$_SESSION' superglobal variable before session start, resulting in data being overwritten once a session begins. On subsequent calls, the validators have no data against which to compare, making the sessions automatically valid. Patched versions ensure that validators are run only after the session has begun, and thus validate sessions correctly.
Upgrade Zend Framework to version 2.3.4 or later. If version 2.3.x is not available, version 2.2.9 is also patched for this vulnerability.