icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Mozilla Thunderbird 3.1.x < 3.1.7 Multiple Vulnerabilities

Medium

Synopsis

The remote host has an email client installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Thunderbird 3.1.x prior to 3.1.7 are affected by the following vulnerabilities :

- Multiple memory corruption issues could lead to arbitrary code execution. (MFSA 2010-74) - On the Windows platform, when 'document.write()' is called with a very long string a buffer overflow could be triggered. (MFSA 2010-75) - Downloadable fonts could expose vulnerabilities in the underlying OS font code. (MFSA 2010-78)

Solution

Upgrade to Thunderbird 3.1.7 or later.