icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Gallery < 2.2.4 Multiple Vulnerabilities

High

Synopsis

The remote host is Missing a critical security patch or upgrade

Description

The remote host is running Gallery, a web-based photo album application written in PHP. The version of Gallery installed on the remote host is less than 2.2.5. The vendor has reported multiple security flaws in this version. The software is prone to a cross-site scripting flaw which could allow an attacker to execute arbitrary script code within client browsers. The software is prone to an information disclosure flaw within the 'album-select' module and the 'embed.php' script which would allow an attacker to gain access to confidential data. The software is prone to a privilege escalation flaw which would allow users the ability to gain access to confidential files or processes. Finally, the software is vulnerable to a security bypass flaw which would allow an attacker the ability to view confidential data.

Solution

Upgrade to version 2.2.3 or newer