icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Ultimate PHP Board chat/login.php username Parameter Script Injection

Medium

Synopsis

The remote host is vulnerable to a Script Injection attack.

Description

The remote host is running Ultimate PHP Board, a message board written in PHP. Versions of Ultimate less than 2.0b2 are vulnerable to a flaw where remote attackers can inject and execute script code. Code would be executed with the privileges of the web server process. The root flaw is in the 'username' parameter of the 'chat/login.php' script. After uploading the code, the attacker can execute via the 'chat/text.php' script. Successful exploitation results in the attacker impacting confidentiality, integrity, and availability.

Solution

No solution is known at this time.