icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Horde < 3.1.1 Help Viewer Code Execution

High

Synopsis

The remote web server contains a PHP application that allows execution of arbitrary PHP code.

Description

The remote web server contains a PHP application that allows execution of arbitrary PHP code. The version of Horde installed on the remote host fails to sanitize user-supplied input before using it in the Help viewer to evaluate code. An unauthenticated attacker could exploit this flaw to execute arbitrary command on the remote host subject to the privileges of the web server user ID.

Solution

Upgrade to version 3.1.1 or higher.