icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Brooky CubeCart < 3.0.7 connector.php Arbitrary File Upload

Medium

Synopsis

The remote host is vulnerable to a Script Injection attack.

Description

The remote host is running Brooky CubeCart, an online storefront application written in PHP. This version of CubeCart is vulnerable to a flaw where arbitrary PHP code can be uploaded to the web server and then executed with the permissions of the web server process. Successful exploitation would only require that the attacker can send malformed HTTP requests to the application.

Solution

Upgrade to version 3.0.7 or higher.