icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

dotProject < 2.0.2 Multiple Script Remote File Inclusion

High

Synopsis

The remote web server contains a PHP application that is affected by multiple remote file inclusion vulnerabilities.

Description

The remote host is running dotProject, a web-based, open-source project management application written in PHP. The installed version of dotProject fails to sanitize user input to various parameters and scripts before using it in calls to PHP functions such as 'include', and 'require_once()'. Provided PHP's 'register_globals' setting is enabled, an unauthenticated attacker may be able to leverage these issues to view arbitrary files or to execute arbitrary PHP code on the remote host, subject to the privileges of the web server user ID.

Solution

Upgrade to version 2.0.2 or higher.