icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

phpBB < 2.0.16 viewtopic.php Arbitrary Code Execution

Medium

Synopsis

The remote host is vulnerable to a Script Injection attack.

Description

The remote host is running phpBB, a web-based forum application written in PHP. There is a flaw in this version of phpBB that will allow remote attackers to inject arbitrary code into the 'viewtopic.php' script. An attacker exploiting this flaw would only need to be able to send an HTTP request to the vulnerable script. Successful execution would result in the attacker executing code with the permissions of the webserver.

Solution

Upgrade to version 2.0.16 or higher.