icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PhotoPost < 5.02 RC3 Multiple Content-parsing Vulnerabilities

High

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running PhotoPost, a web-based image gallery written in PHP. This version of PhotoPost is reported vulnerable to multiple vulnerabilities. Multiple scripts are reported prone to a Cross-Site Scripting (XSS) vulnerability. Exploiting the XSS flaws may enable an attacker to inject arbitrary script code into the browser of unsuspecting users. A successful attack would potentially allow the attacker the ability to view confidential data (cookies, authentication data, and more) or compromise the integrity of the local system via the web browser. A second set of issues also affect multiple scripts. Specifically, multiple scripts are vulnerable to a remote SQL injection attack. An attacker exploiting this flaw would be able to view and modify database data as well as potentially execute arbitrary commands.

Solution

Upgrade to PhotoPost 5.02 Release Candidate 3 or higher.