icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PhotoPost Multiple Vulnerabilities

High

Synopsis

The remote host is vulnerable to an HTML injection attack.

Description

The remote host is running PhotoPost, a web-based image gallery written in PHP. This version of PhotoPost is reported to be vulnerable to multiple flaws. Specifically, the host is reported vulnerable to an access validation flaw within the 'adm-photo.php' script. An attacker exploiting this flaw would be able to upload images under the context of another user. The second flaw is a Cross-Site Scripting (XSS) vulnerability. Exploiting the XSS flaw may enable an attacker to inject arbitrary script code into the browser of unsuspecting users. A successful attack would potentially allow the attacker the ability to view confidential data (cookies, authentication data, and more) or compromise the integrity of the local system via the web browser.

Solution

Upgrade to a version of PhotoPost greater than 5.00 Release Candidate 3.