Triangle MicroWorks SCADA Data Gateway < 3.3.729 Heartbeat Information Disclosure (Heartbleed)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by the Heartbleed vulnerability.

Description :

The remote host has a version of SCADA Data Gateway installed that is
prior to 3.3.729. It is, therefore, affected by an out-of-bounds read
error, known as the 'Heartbleed Bug' in the included OpenSSL version.

This error is related to handling TLS heartbeat extensions that could
allow an attacker to obtain sensitive information such as primary key
material, secondary key material, and other protected content. Note
this affects both client and server modes of operation.

Note that Nessus has not tested for this issue, but has instead relied
only on the application's version number.

See also :

http://www.nessus.org/u?980bdd7b

Solution :

Upgrade to SCADA Data Gateway 3.3.729 or later.

Risk factor :

High / CVSS Base Score : 9.7
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:P)
CVSS Temporal Score : 8.4
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: SCADA

Nessus Plugin ID: 76575 ()

Bugtraq ID: 66690

CVE ID: CVE-2014-0160