LibreOffice 4.2.x < 4.2.3 OpenSSL Multiple Vulnerabilities (Mac OS X) (Heartbleed)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by an
information disclosure vulnerability.

Description :

A version of LibreOffice 4.2.x prior to 4.2.3 is installed on the
remote Mac OS X host. This version of LibreOffice is bundled with a
version of OpenSSL affected by multiple vulnerabilities :

- An error exists in the function 'ssl3_read_bytes'
that could allow data to be injected into other
sessions or allow denial of service attacks. Note
this issue is only exploitable if
'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- An error exists in the 'ssl3_take_mac' function in the
file 'ssl/s3_both.c' related to handling TLS handshake
traffic that could lead to denial of service attacks.
(CVE-2013-4353)

- An error exists in the 'ssl_get_algorithm2' function in
the file 'ssl/s3_lib.c' related to handling TLS 1.2
traffic that could lead to denial of service attacks.
(CVE-2013-6449)

- An error exists related to the handling of DTLS
retransmission processes that could lead to denial of
service attacks. (CVE-2013-6450)

- An out-of-bounds read error, known as the 'Heartbleed
Bug', exists related to handling TLS heartbeat
extensions that could allow an attacker to obtain
sensitive information such as primary key material,
secondary key material, and other protected content.
(CVE-2014-0160)

- A buffer overflow error exists related to invalid DTLS
fragment handling that could lead to execution of
arbitrary code. Note this issue only affects OpenSSL
when used as a DTLS client or server. (CVE-2014-0195)

- An error exists in the function 'do_ssl3_write' that
could allow a NULL pointer to be dereferenced leading
to denial of service attacks. Note this issue is
exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is
enabled. (CVE-2014-0198)

- An error exists related to DTLS handshake handling that
could lead to denial of service attacks. Note this
issue only affects OpenSSL when used as a DTLS client.
(CVE-2014-0221)

- An unspecified error exists that could allow an
attacker to cause usage of weak keying material
leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH
cipher suites that could allow denial of service
attacks. Note this issue only affects OpenSSL TLS
clients. (CVE-2014-3470)

Note that Nessus has not attempted to exploit these issues, but has
instead relied only on the application's self-reported version number.

See also :

http://www.libreoffice.org/about-us/security/advisories/cve-2014-0160/
http://www.heartbleed.com
https://eprint.iacr.org/2014/140
https://www.openssl.org/news/vulnerabilities.html#2014-0160
https://www.openssl.org/news/secadv/20140407.txt
https://www.openssl.org/news/secadv/20140605.txt

Solution :

Upgrade to LibreOffice version 4.2.3 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial