OpenSSL 1.0.1 < 1.0.1h Multiple Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote web server uses a version of
OpenSSL 1.0.1 prior to 1.0.1h. The OpenSSL library is, therefore,
affected by the following vulnerabilities :

- A race condition exists in the ssl3_read_bytes()
function when SSL_MODE_RELEASE_BUFFERS is enabled. This
allows a remote attacker to inject data across sessions
or cause a denial of service. (CVE-2010-5298)

- A buffer overflow error exists related to invalid DTLS
fragment handling that can lead to execution of
arbitrary code. Note this issue only affects OpenSSL
when used as a DTLS client or server. (CVE-2014-0195)

- An error exists in the do_ssl3_write() function that
allows a NULL pointer to be dereferenced, resulting in a
denial of service. Note that this issue is exploitable
only if 'SSL_MODE_RELEASE_BUFFERS' is enabled.
(CVE-2014-0198)

- An error exists related to DTLS handshake handling that
could lead to denial of service attacks. Note that this
issue only affects OpenSSL when used as a DTLS client.
(CVE-2014-0221)

- An unspecified error exists that allows an attacker to
cause usage of weak keying material leading to
simplified man-in-the-middle attacks. (CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH
ciphersuites that could allow denial of service
attacks. Note this issue only affects OpenSSL TLS
clients. (CVE-2014-3470)

- An integer underflow condition exists in the
EVP_DecodeUpdate() function due to improper validation
of base64 encoded input when decoding. This allows a
remote attacker, using maliciously crafted base64 data,
to cause a segmentation fault or memory corruption,
resulting in a denial of service or possibly the
execution of arbitrary code. (CVE-2015-0292)

See also :

http://www.openssl.org/news/secadv_20140605.txt
http://www.openssl.org/news/vulnerabilities.html#CVE-2010-5298
http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0195
http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0198
http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0221
http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0224
http://www.openssl.org/news/vulnerabilities.html#CVE-2014-3470
http://ccsinjection.lepidum.co.jp/
https://www.imperialviolet.org/2014/06/05/earlyccs.html

Solution :

Upgrade to OpenSSL 1.0.1h or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true