RHEL 5 / 6 : flash-plugin (RHSA-2014:0496)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated Adobe Flash Player package that fixes multiple security
issues is now available for Red Hat Enterprise Linux 5 and 6
Supplementary.

The Red Hat Security Response Team has rated this update as having
Critical security impact. Common Vulnerability Scoring System (CVSS)
base scores, which give detailed severity ratings, are available for
each vulnerability from the CVE links in the References section.

The flash-plugin package contains a Mozilla Firefox compatible Adobe
Flash Player web browser plug-in.

This update fixes multiple vulnerabilities in Adobe Flash Player.
These vulnerabilities are detailed in the Adobe Security Bulletin
APSB14-14, listed in the References section.

Multiple flaws were found in the way flash-plugin displayed certain
SWF content. An attacker could use these flaws to create a specially
crafted SWF file that would cause flash-plugin to crash or,
potentially, execute arbitrary code when the victim loaded a page
containing the malicious SWF content. (CVE-2014-0510, CVE-2014-0517,
CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)

A flaw in flash-plugin could allow an attacker to bypass the
same-origin policy. (CVE-2014-0516)

All users of Adobe Flash Player should install this updated package,
which upgrades Flash Player to version 11.2.202.359.

See also :

https://www.redhat.com/security/data/cve/CVE-2014-0510.html
https://www.redhat.com/security/data/cve/CVE-2014-0516.html
https://www.redhat.com/security/data/cve/CVE-2014-0517.html
https://www.redhat.com/security/data/cve/CVE-2014-0518.html
https://www.redhat.com/security/data/cve/CVE-2014-0519.html
https://www.redhat.com/security/data/cve/CVE-2014-0520.html
https://helpx.adobe.com/security/products/flash-player/apsb14-14.html
http://rhn.redhat.com/errata/RHSA-2014-0496.html

Solution :

Update the affected flash-plugin package.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : true

Family: Red Hat Local Security Checks

Nessus Plugin ID: 74020 ()

Bugtraq ID: 66241
67361
67364
67371
67372
67373

CVE ID: CVE-2014-0510
CVE-2014-0516
CVE-2014-0517
CVE-2014-0518
CVE-2014-0519
CVE-2014-0520