VMware Fusion 6.x < 6.0.3 OpenSSL Library Multiple Vulnerabilities (VMSA-2014-0004) (Heartbleed)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.

Synopsis :

The remote host has a virtualization application that is affected by
multiple vulnerabilities.

Description :

The version of VMware Fusion 6.x installed on the remote Mac OS X host
is prior to 6.0.3. It is, therefore, reportedly affected by the
following vulnerabilities in the OpenSSL library :

- An error exists related to the implementation of the
Elliptic Curve Digital Signature Algorithm (ECDSA) that
could allow nonce disclosure via the 'FLUSH+RELOAD'
cache side-channel attack. (CVE-2014-0076)

- An out-of-bounds read error, known as the 'Heartbleed
Bug', exists related to handling TLS heartbeat
extensions that could allow an attacker to obtain
sensitive information such as primary key material,
secondary key material and other protected content.

See also :


Solution :

Upgrade to VMware Fusion 6.0.3 or later.

Risk factor :

High / CVSS Base Score : 9.4
CVSS Temporal Score : 8.2
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 73670 ()

Bugtraq ID: 66363

CVE ID: CVE-2014-0076