Oracle Secure Global Desktop Multiple Vulnerabilities (April 2014 CPU)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host has a version of Oracle Secure Global Desktop that is
affected by multiple vulnerabilities.

Description :

The remote host has a version of Oracle Secure Global Desktop that is
version 4.63, 4.71, 5.0 or 5.1. It is, therefore, affected by the
following vulnerabilities :

- A buffer overflow flaw exists in the 'bdfReadCharacters'
function within 'bitmap/bdfread.c' of the included X.Org
libXfont. This could allow a remote attacker to cause a
denial of service attack or possibly execute arbitrary
code. (CVE-2013-6462)

- A flaw exists with the Workspace Web Application. This
could allow a remote attacker to impact the integrity of
the application. Note this only affects versions
5.0 and 5.1 of Oracle Secure Global Desktop.
(CVE-2014-2439)

- A flaw exists with the Workspace Web Application. This
could allow a remote attacker to impact the
confidentiality and integrity of the application.
(CVE-2014-2463)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported patch information.

See also :

http://www.nessus.org/u?23999f63

Solution :

Apply the appropriate patch according to the April 2014 Oracle
Critical Patch Update advisory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 73596 ()

Bugtraq ID: 64694
66854
66860

CVE ID: CVE-2013-6462
CVE-2014-2439
CVE-2014-2463