GLSA-201402-27 : pidgin-knotify: Arbitrary code execution

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201402-27
(pidgin-knotify: Arbitrary code execution)

pidgin-knotify does not properly sanitize shell metacharacters from
received messages.

Impact :

A remote attacker could send a specially crafted instant message,
possibly resulting in execution of arbitrary code with the privileges of
the Pidgin process.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201402-27.xml

Solution :

Gentoo has discontinued support for pidgin-knotify. We recommend that
users unmerge pidgin-knotify:
# emerge --unmerge 'x11-plugins/pidgin-knotify'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.1
(CVSS2#E:ND/RL:U/RC:ND)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 72718 ()

Bugtraq ID: 43206

CVE ID: CVE-2010-3088