GLSA-201402-15 : Roundcube: Arbitrary code execution

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201402-15
(Roundcube: Arbitrary code execution)

A vulnerability in steps/utils/save_pref.inc allows remote attackers to
use the _session parameter to change configuration settings.

Impact :

A remote attacker could possibly execute arbitrary code with the
privileges of the process, inject SQL code, or read arbitrary files.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201402-15.xml

Solution :

All Roundcube 0.9 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=mail-client/roundcube-0.9.5'
All Roundcube 0.8 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=mail-client/roundcube-0.8.7'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 72452 ()

Bugtraq ID: 63300

CVE ID: CVE-2013-6172