Amazon Linux AMI : xorg-x11-server Buffer Overflow Vulnerability (ALAS-2014-277)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

An integer overflow, which led to a heap-based buffer overflow, was
found in the way X.Org server handled trapezoids. A malicious,
authorized client could use this flaw to crash the X.Org server or,
potentially, execute arbitrary code with root privileges.
(CVE-2013-6424)

See also :

http://www.nessus.org/u?48c17469

Solution :

Run 'yum update xorg-x11-server' to update your system.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 72295 ()

Bugtraq ID:

CVE ID: CVE-2013-6424